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INTRODUCTION
SQL Sentry Plan Explorer is a free, lightweight .NET-based tool that builds upon and 
supplements the capabilities of SSMS for execution plan analysis. In general, the more 
complex the execution plan, the more useful the tool will be.

Originally, this functionality was planned only for the full version of SQL Sentry v6. However, 
after using it ourselves for a while and seeing how useful it can be for plan analysis, we 
decided that anyone that wants it should be able to have it.

As such, Plan Explorer contains almost all plan analysis functionality provided by the full 
version integrated within the SQL Sentry Console.

Since Plan Explorer is a simple standalone app that doesn’t utilize the SQL Sentry database 
or collector service, it doesn’t support historical plan analysis or captured statement 
integration via SQL Sentry’s Top SQL collection. It does, however, support 
opening .QueryAnalysis files generated by the full version of SQL Sentry. These files can 
contain actual captured statements, and provide estimated and actual metrics side-by-side 
for those statements.

2 Introduction
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PLAN EXPLORER FEATURES
Below are links to the primary features of Plan Explorer. Since the graphical plan diagram in 
SSMS was used as a starting point for the design of Plan Explorer, some features are 
compared with the current capabilities of SSMS in order to illustrate the reasoning behind 
the feature.

General (Section 3.1)

Plan Diagram (Section 3.4.1)

GENERAL
 The “Statements Tree” pane shows a tree list representation of the entire query call 

stack, including all statements, conditional logic structures, looping structures, nested 
procedure calls, and dynamic SQL calls.  Estimated costs (Total, CPU, and IO), 
estimated rows, and operation counts are displayed for each statement.  Actual costs 
and rows are shown side-by-side (Top SQL collection and .QueryAnalysis files only). 

 Significant differences between estimated and actual rows for captured statements are 
highlighted, making it easy to spot cases where statistics may be stale (Top SQL 
collection and .QueryAnalysis files only). 

 The graphical plan diagram (and other tabs) are synchronized with the selected 
statement, versus trying to show all plans together in a large list. The list can be used to 
quickly find the highest cost statements. Selecting any statement will show the graphical 
diagram, top operations list, columns list, and tree list view for that statement’s execution 
plan.
For actual plans, SSMS lists all plans in a single view with estimated costs in the header 
for each individual plan.  For estimated plans, subtrees are created for each statement 
and plan. There is no way to quickly sort or find the highest cost statement in either case. 
Because of this “load everything at once” approach, very large plans can cause 
significant performance issues for SSMS.

 The graphical query plan and color-coded query text view is synchronized with the 
statement list.
SSMS has no synchronization between the query text and graphical plan, requiring 

3 Plan Explorer Features

3.1 General
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manual scrolling.

 Screen and window layout is persisted by default, and can be saved to and loaded from 
disk. Default horizontal and vertical layout styles are included. Horizontal layout is better 
for shorter queries with wide plans, and vertical layout better for longer queries. 

 Scans and lookups are background highlighted on all views by default if the est row count 
exceeds 100. 

 Tree list view of plan provides a hierarchical view of the plan with estimated costs and 
other operation details. 

 Top Operations view is a sortable list view of all plan operations, sorted descending by 
total cost by default so you can immediately see the highest cost operations.
SSMS provides no sorting capabilities.

 Columns view shows exactly how data is accessed for each column used by the query, 
including the associated operation and estimated rows. This view makes it easy to 
identify bookmark lookups or index scans occurring because indexes are non-covering. 

 To inspect or make modifications to an index, the index properties window can be 
opened by right-clicking any index operation node on the graphical plan, or any grid row 
on the other tabs. Likewise you can create new indexes via a separate context item. (Full 
version only)
This functionality was available for SQL Server 2000 in Enterprise Manager, but removed 
from SSMS starting with SQL Server 2005.

 The graphical plan diagram, tree view, top operations, and columns view are 
synchronized, so an operation selected in one view will be auto-selected on all others. 

 Entire plans can be saved to and loaded from file using the .QueryAnalysis format, 
complete with all statement and plan info. 

 Plan TSQL and XML can be saved to file. 

COMMAND TEXT
 This section shows an editable version of the query text for the statement or batch being 

analyzed. 

 You can make changes to the query and then, to see how this impacts the execution 
plan, you can click on the "Estimated Plan" or "Actual Plan" button on the toolbar. 

 In either case, you will be asked for the server, database and credentials in order to 
connect (unless you launched Plan Explorer from within SSMS using our Management 
Studio Add-In (http://www.sqlsentry.com/plan-explorer/sql-server-query-

3.2 Command Text and Statements Tree Section
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view.asp#addin)). To generate the actual plan, the query is run against the server, but 
the actual query results are not returned to the Plan Explorer UI. By default there is a 
message box explaining this behavior, but it can be turned off by enabling the Help menu 
option, "Warn on Actual Plan Execution." 

 Generating the actual execution plan by executing the query against the server allows 
you to collect actual runtime metrics, such as duration, CPU and reads, which you cannot 
get from an estimated or actual plan on its own. 

STATEMENTS TREE
 The Statements Tree represents one of the biggest differences between SQL Sentry 

Plan Explorer and SSMS. Its function is critical when navigating multi-statement plans. 
What it shows is a logical breakdown of the entire plan tree, including all control 
structures, nested procedure calls, and estimated and/or actual metrics for each 
statement, including operation counts. 

 Click on any statement in the grid to be shown the associated plan for that statement 
only. 

 Click on any control structure (IF or WHILE) or EXEC higher up the tree to see a filtered 
view of the plan starting from that point. 

 Sort the statements list and the highest cost trees and statements will immediately 
bubble up to the top. 

 So whether there are 10 or 1,000 statements in the master plan doesn't really matter, it's 
trivial to find the highest cost individual plans so you can focus your attention on those. 
Big plans that simply weren't usable before can now be managed with ease. 

 GENERAL QUERY & PLAN INFO SECTION
 This section contains two tabs: 

 Text Data 
 Plan XML 

 If you loaded an existing execution plan, the T-SQL and plan XML will be auto-generated. 

 If you modify the query in the Command Text tab, the query text and XML will be 
synchronized when you generate a new Estimated or Actual plan from the toolbar. 

3.3 General Query and Plan Info Section
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 Like plans, the T-SQL statements are synchronized with the Statements Tree, meaning 
that if you select a row on the tree view it will auto-select the associated T-SQL statement 
and its execution plan, and vice versa. 

PLAN DETAILS SECTION
This section contains up to seven tabs:

Plan Diagram (Section 3.4.1)

Plan Tree (Section 3.4.2)

Top Operations (Section 3.4.3)

Query Columns (Section 3.4.4)

Join Diagram (Section 3.4.5)

Parameters (Section 3.4.6)

Expressions (Section 3.4.7)

PLAN DIAGRAM
 The Plan Diagram view will certainly be recognized by everyone familiar with SSMS, 

although you should immediately notice some differences. First, there is color! The cost 
information is color-scaled so you can quickly see which operations are heaviest, and 
Lookups and Scans are also highlighted. 

 Right-click the diagram and context menus provide access to a variety of other functions. 
Using the context menus, in addition to scaling by total cost (CPU + I/O), you can also 
use CPU or I/O separately. This can be very helpful if your hardware is more I/O 
constrained than CPU constrained, or vice versa. To see which subtrees are most 
expensive, select the "Cumulative Costs" context item. 

 Optimized layout algorithms render plans in a more condensed view than SSMS, so 
more of the plan fits on the screen without having to zoom out.
In SSMS, each subtree starts one row down from the previous subtree, even if there is 
sufficient space to display it on the same row.  So the more subtrees the taller the plan, 
and the more scrolling and zooming required to work with it.

 Optimized plan node labels prevent truncation of object names in most cases, and there 
is an option to disable truncation completely so full object names are always visible.

3.4 Plan Details Section

3.4.1 Plan Diagram
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Object name truncation is a common issue in SSMS, and requires inspecting the tooltip 
to verify the object name.

 Optimized tooltips prevent wrapping of object names, column names and predicates.
These elements are typically jumbled and wrapped in SSMS, making them difficult to 
read and process.

 Estimated costs are displayed above nodes for maximum readability.
SSMS lists costs on the bottom with the other text, so the row it uses will change 
depending on the operation.

 Estimated costs label uses color scaling by CPU, IO, or CPU+IO so highest cost 
operations are instantly obvious, even on larger plans.
SSMS doesn’t provide color scaling.

 Costs are shown to the first decimal place.
SSMS rounds costs to the nearest integer.

 Connector line width can be scaled by either Rows or Data Size.
SSMS only scales width by rows.

 “Rows” and “Data Size” are displayed above connector lines.
SSMS doesn’t show this information on the diagram, only in tooltips.

 Connector lines for bookmark (key|rid) lookups, table spools, and function calls show the 
actual estimated rows or data size, and line width is scaled accordingly.
SSMS always shows a thin line with “1” as the row count for these operations in 
estimated plans, although it shows the actual rows for actual plans.  This behavior is 
inconsistent and can be deceiving.

 Cumulative costs can be shown in lieu of per node costs, and when combined with color 
scaling it’s easy to see which subtrees are contributing most to the plan cost.
SSMS supports only per node costs.

 The mouse scroll wheel can be used for both scrolling up down, and zooming in/out (by 
holding Ctrl).
The scroll wheel is non-functional for SSMS plan diagrams.

PLAN TREE 
Plan Tree shows all operations and associated metrics. On the surface it looks similar to a 
showplan_all, however it's different in several respects:

 You can expand and collapse sections, and sort within levels. 

3.4.2 Plan Tree
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 Additional metrics are shown, such as "Estimated Data Size", as well as "Actual Rows" 
and "Actual Data Size" for actual plans, side-by-side with the estimates. There are many 
other plan metrics available by right-clicking any column header and selecting "Column 
Chooser". 

 Significant differences between estimates and actuals are highlighted. 

 Possibly problematic operations like scans and bookmark (key / rid) lookups are 
highlighted. 

TOP OPERATIONS 

 A simple list of all plan operations, by default ordered by highest estimated cost first. 

 Sort by any of the other columns, as well as group by operation type, object, and other 
criteria. 

 Same highlighting as the Plan Tree for potentially problematic operations, and again the 
"Column Chooser" allows you to add attributes that are not shown by default. 

QUERY COLUMNS 
 Shows a list of all columns accessed by the query, for whatever reason (sarg, join, output 

list, sort), along with the table, operation, and index used. 

 Columns for related operations are grouped together (indicated by a thick separator bar), 
with the indexes used and bookmark (key / rid) lookup columns highlighted in orange. 
This makes it easy to see how indexes can be modified to eliminate lookups. 

3.4.3 Top Operations

3.4.4 Query Columns
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 JOIN DIAGRAM
 If there are joins present in the query, this tab will be present, showing a visual 

representation of the joins involved. Similar to the database diagram or Query Designer 
features within Management Studio - but only showing the columns that actively 
participate in joins. 

 Unlike the join information included in the plan in SSMS, Plan Explorer looks past any 
views and shows the base tables and base columns, making it quicker to analyze queries 
that involve, for example, nested views. 

PARAMETERS 
 Shows compiled and runtime parameters referenced in the plan, if any exist (otherwise 

the tab is not visible). 

 For an estimated plan, it will only show the compiled parameter value; for an actual plan, 
you can compare compiled values with runtime, which can in turn help point out potential 
parameter sniffing issues. 

EXPRESSIONS 
 If there are any expressions in the plan, Plan Explorer shows a tab to list these 

(previously expressions were listed only in tooltips). 

 You can see the operator type, the shorthand expression name and the expanded 
version of the expression, as well as any other expressions that reference it or are 
referenced by it, allowing you to quickly see if you are 

3.4.5 Join Diagram

3.4.6 Parameters

3.4.7 Expressions
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VIEWING QUERY PLANS
There are multiple ways to view a query plan in Plan Explorer:

 Using the Management Studio Add-In (http://www.sqlsentry.com/plan-explorer/sql-
server-query-view.asp#addin) (a separate install), right-click a plan in SSMS and 
choose, “View with SQL Sentry Plan Explorer.” This will open the plan(s) in Plan 
Explorer, providing the correct server/database context for further operations. 

 In SSMS, right-click a graphical plan and select “Show Execution Plan XML”, then copy 
and paste the plan XML into Plan Explorer. It doesn’t matter which pane is active, the 
clipboard handler is global and will auto-detect plan XML. This makes it quick and easy to 
move plans from SSMS into Plan Explorer if you’re not using the SSMS add-in. 

 Save an execution plan from SSMS to a .sqlplan file, then open the file using the Open 
toolbar button or File->Open. Raw plan XML files and .QueryAnalysis files are also 
supported. 

 Right-click an existing .sqlplan file and select “Open with -> SQL Sentry Plan Explorer”. 

 Drag-and-drop a plan file onto the application. 

 Retrieve the estimated or actual plan from T-SQL in the Command Text pane using the 
"Estimated Plan" or "Actual Plan" button on the toolbar. The connection dialog box will 
open to connect to a valid SQL Server instance (unless Plan Explorer was launched 
using the add-in, in which case the connection information will be pre-populated). 

4.1.1  RETRIEVING THE ESTIMATED PLAN
Copy and paste, or type raw TSQL into the Text Data pane, then hit F5 or click the “Retrieve 
Estimated Plan” toolbar button to connect to a server and get the estimated plan.

4.1.2  PLAN DIAGRAM CONTEXT MENUS
Once you have a plan loaded, right-click anywhere in the diagram area to access context 
menus, which control how the graphical plan is displayed. By default, color-scaling and per 
node costs are enabled.

4.1.3  ACTUAL PLANS
If an actual plan is loaded, actual metrics are shown by default. You can quickly toggle the 
plan diagram back and forth between estimated and actual metrics using the “Show 
Estimated Plan” toolbar button. This button is only enabled when an actual plan is loaded.

4 Using Plan Explorer

4.1 Viewing Query Plans
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GENERATING AN ACTUAL PLAN
Generating the actual execution plan by executing the query against the server allows you to 
collect actual runtime metrics, such as duration, CPU and reads, which you cannot get from 
an estimated or actual plan on its own.

NOTE: You can enable or disable the warning message you get when generating an actual 
plan using the option “Warn on Actual Plan Execution” in the Help menu.

4.2 Generating an Actual Plan
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QUERY ANALYSIS FILES 

All information shown in the Plan Explorer can be saved to the .QueryAnalysis file format by 
clicking the Save toolbar button.  This proprietary, portable format contains the plan XML 
along with additional information, including actual statements and actual metrics captured via 
SQL Sentry’s Top SQL trace.  This means that DBAs can easily save all estimated and 
actual data for a query to file for later analysis, or share it with other team members.  For 
example, a DBA using the full version of SQL Sentry can send a .QueryAnalysis file to a 
developer for tuning, and all the developer needs is the Plan Explorer utility, versus the 
entire SQL Sentry Console application.

EXCEPTION REPORTER

If you are working in the Plan Explorer and see a small form pop-up unexpectedly, it means 
we’ve captured an unhandled exception. If you would, please enter your name and email 
address along with brief steps to reproduce into the textbox, then submit it – it comes to us 
via secure web service.  If the exception seems to pertain to a particular plan, please also 
save it to a .QueryAnalysis file and email to support@sqlsentry.net.

CHECKING FOR UPDATES 

Plan Explorer can check our servers to ensure you are using the most recent version, and 
offer to update your software if there is a newer version available. You can do this manually 
by using Help > Check for Updates, and by default it will also check each time you launch 
the application. You can disable this automatic check through an option in the Help menu.

5 Appendix

5.1 Query Analysis Files

5.2 Exception Reporter

5.3 Checking for Updates
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